Css code doesn't work with another code in function.php


#1

Hey again guys

I use two css codes that works delightful for what I need.

code

.post .post-info,
.post .entry-meta {
    display: none !important;
}
.single-post .buy-button {
    display: none;
}

This code isn’t working if I use the next one: (this improves my website speed very much ) How can I use both? The second one I put it in Functions.php

function _remove_script_version( $src ){
    $parts = explode( '?', $src );
    return $parts[0];
}
add_filter( 'script_loader_src', '_remove_script_version', 15, 1 );
add_filter( 'style_loader_src', '_remove_script_version', 15, 1 );

Thanks
Daniel


#2

Hello Daniel,

How did you add the CSS code to your website?

Kind Regards, Roman.


#3

being a novice, with Simple Custom CSS plugin
Thanks


#4

Also when I enter from my mobile (and not only mine) and have the carousel active I see a blank page and I must scroll down a lot to see the content.


#5

Hello Daniel,

Can you please try to use another plugin, for example WP Add Custom CSS or TJ Custom CSS?

Kind Regards, Roman.


#6

yeap first issue solved.

Thanks


#7

Daniel, I don’t see your second issue, have you already resolved it?

Kind Regards, Roman.


#8

Yes, the 2 codes now work together. I use that css code for hiding the author date etc and the buy button inside the pages.

The second issue would be:

when I enter from my mobile (and not only mine) and have the carousel active I see a blank page and I must scroll down a lot to see the content.


#9

Hello Daniel,

Can you please try to deactivate all your plugins and see if it helps?

Kind Regards, Roman.


#10

Thanks for the idea. Unfortunately I tried and it didn’t work. Right now I re-activated all the plugin .


#11

Maybe is related with android versions…I tested with 2x android 4.1.2 (the issue was there) and 2 that have a newer version (and it worked fine).
If this is the problem is fine…my android version is really old I know :)))

Thanks.


#12

Hello Daniel,

It might be the issue. Which browser you are using on that device?

If you are using default browser, then please try Firefox or Chrome.

Kind Regards, Roman.


#13

Yeap I tried with chrome and it works. Before I used the default browser. At least I found out where it is the problem with your help. Now if you can do something it’s great if not…it’s also great you helped me a lot till now and I appreciate.


#14

Hello Daniel,

I’m glad that it’s clarified now as well.

Sometimes old browsers don’t support new stuff, so I think that it’s better to use something like Firefox/Chrome, especially on older devices.

Kind Regards, Roman.


#15

Thanks you so much for all your help


#16

You are welcome Daniel,

Please feel free to ask any other questions that you might have in future.

Kind Regards, Roman.