Crelly Slider not working at all in headers


#1

Hi there,
We have been using your theme for several years now, but have now decided to use the Crelly Slider for our header.

This results in a small blank space and no header.
Trying to use a shortcode and embedding into a test page results in a page that loads infinitely.

I have answered the most common troubleshooting questions to save us some time.

Yes I am using the most up to date version of the plugin and theme,
Yes I have tried reinstalling the plugin,
Yes I have verified the alias name,
Yes I have tried using a different alias name.
Yes, there are slides in the slider,
Yes, the slider has a higher-than-zero minimum height.
No, the slider is not using custom CSS or classes.
No, I am not modifying the header CSS.

I hope to hear from you soon!


#2

Hello there,

From your site admin area, please go to Appearance > Customize > Header area > Header type; ensure Crelly Slider option is enabled.

Regards,
Kharis


#3

I suppose I may have missed that particular entry in the list of things
I have checked.

I have ensured that the crelly slider header type was selected.


#4

Hello there,

Please share a link to your site here, so I can have a look.

Regards,
Kharis


#5

I have restored the normal image header, as we cannot keep a broken front page on the site. www.galileecentre.com is the website, however.


#6

We are still having this issue. The plugin only does anything if the slider is placed on a test page as a shortcode. The only thing that happens is the page loads infinitely and will never display. The following is displayed in the Chrome console.

    Uncaught TypeError: $(...).crellySlider is not a function
        at HTMLDocument.<anonymous> ((index):561)
        at i (jquery.min.js:2)
        at Object.fireWith [as resolveWith] (jquery.min.js:2)
        at Function.ready (jquery.min.js:2)
        at HTMLDocument.K (jquery.min.js:2)

The line that this refers to is:
<script type="text/javascript">(function($){$(document).ready(function(){$("#crellyslider-3").crellySlider({layout:'full-width',responsive:1,startWidth:1140,startHeight:500,automaticSlide:1,showControls:1,showNavigation:1,enableSwipe:1,showProgressBar:1,pauseOnHover:1,randomOrder:0,startFromSlide:0,beforeStart:function(){},beforeSetResponsive:function(){},beforeSlideStart:function(){},beforePause:function(){},beforeResume:function(){},});});})(jQuery);</script>

That is added to the page code when the shortcode is used within it.

You can access this test page at
https://www.galileecentre.com/slider-test/


#7

HI there, We are still struggling with this issue, do you have any input based on the new information?


#8

Hello there,

Really sorry for the long delay. I didn’t mean to. But I didn’t get any email notifications of your last replies.

What will happen if you temporarily disable your current active Crelly Slider, and re-create the fresh one?

Regards,
Kharis


#9

So, the crelly slider that I used to test on that page was freshly created.


#10

After another issue arose on our site today, I disabled a plugin that forced all connections to use HTTPS. This resolved most of the issue, and the test slider now appears, however breaks other elements on unrelated pages.

**UPDATE: The issue was caused by a conflict between the Bootstrap Jquery and the JQuery used in this plugin. It is likely that one was loaded first and the other was not loaded at all, resulting in the functions required for the crelly slider not being available. Whatever caused this to happen, I have begun to only use the JQuery included in the Perth theme, rather importing the BS3 JQuery in the header. **


#11

Hello there,

If I got your last reply correctly, it seems like the issue was sorted out. Glad to hear that. Please let us know in a new topic if you have other else we could help.

Have a nice day!

Regards,
Kharis