Costum link to text widget

Hi Support,

Is it possible to make custom links to text widgets on a row?

see: www.janzaal.nl/vvt/nederlands. I like to make custom links to each text widget.

Hi,
firstly, you have to get the element ID for the section/row (you can use chrome google dev > inspect element to get the elelment ID).

for example, the element ID for the row is panel-99-0-0-0, then you have to put those element ID for the menu by adding # prefix. So, your link for the menu should be like this #panel-99-0-0-0 or http://yourdomain.com/#panel-99-0-0-0

Regards,
Awan

Hi Awan,

Thanks. This works but not perfect. F.e. It does not work in the menu on the homepage. In the menu on the “Nederlands” page it works but the elements does not scroll to the center of the page. The only element that scrolls to the correct position is the last one “Contact”. Pls. have a look at www.janzaal.nl/vvt to see what I mean.

Hope you can help me to fixe this.

Hi,

I think its need more custom CSS to do it, please try add these CSS also:

#pg-99-0 .siteorigin-panels-stretch.panel-row-style {
    background-position: 0 !important;
}

#pgc-99-0-0 .widget_text {
    padding-top: 200px;
}

Regards,
Awan

Hi Awan,

Tanks! This works but still not on the homepage. This will be no problem if the submenu on the homepage can be hidden. Is that possible?

Thanks in advance and have a nice day.

Hi Awan,

Because of another problem I had with the text I had to replace all wp text widgets by SiteOrigin editor widgets and therefor all text blocs are much higher than before and the css below does not work anymore.

Have you any suggestions how I can change this?

#pg-99-0 .siteorigin-panels-stretch.panel-row-style {
background-position: 0 !important;
}

#pgc-99-0-0 .widget_text {
padding-top: 200px;
}

Hi,

Here is the CSS code to disable the submenu on the home page:

.home #mainnav li:hover > .sub-menu {
    display: none !important;
}

And when I re-checked your site, I can see the last CSS code in above are still working.

Regards,
Awan

Thaniks Awan.

Works perfect.

Have nice day.

Hi Awan,
I now the CSS code is still working but probalby I dit not explain clearly what my problem is.

After click on “Nederlands” on homepage the “Nederlands” page is showed but with the first text widget aligned to the bottom of the page. With a click on “Over ons” in the submenu the text widget moves up to the right position. Is it possible that this widget is on the right position from the start?

I see, please find this in your existing custom CSS code:

@media (min-width: 1025px){
  #panel-99-0-0-0, #panel-99-0-0-1, #panel-99-0-0-2, #panel-99-0-0-3, #panel-99-0-0-4 {
    padding-top: 200px;
    margin-top: -200px;
  }
}

Then remove this line: margin-top: -200px;

Hi Awan,

I asume the CSS code has to look like this:

@media (min-width: 1025px) {
#panel-99-0-0-0,
#panel-99-0-0-1,
#panel-99-0-0-2,
#panel-99-0-0-3,
#panel-99-0-0-4 {
padding-top: 200px;

Sorry but this does not work.

I have changed the CSS code into this:

@media (min-width: 1025px){
#panel-99-0-0-0, #panel-99-0-0-1, #panel-99-0-0-2, #panel-99-0-0-3, #panel-99-0-0-4 {
padding-top: 200px;
margin-top: -300px;

And it works!