Contact Us - Perth Pro II - Google Map doesn't Load

Hello,

I have started creating a new website and the contact us page loads except for the Google Maps section.

I have used the Contact template used the correct address.

The error I receive is:

Sorry! Something went wrong.
This page didn’t load Google Maps correctly. See the JavaScript console for technical details.

URL: http://www.dev.emplussolutions.com.au/?page_id=16

Also another issue is that I have changed the theme colour from Blue to Red and as you can see in the link that the icons on the right (contact page) are blue and should be RED.

Hello there,

I would like to apologize in advance for inconvenience.

It happens due to Google now requires a JavaScript API key/authentication to use the Google Map service. To temporary fix it, please edit the header-contact.php file in the child theme mode. Replace this line:


<script type="text/javascript" src="https://maps.googleapis.com/maps/api/js?sensor=false"></script>

with:


<script type="text/javascript" src="https://maps.googleapis.com/maps/api/js?sensor=false&key=YOUR_API_KEY"></script>

Replace YOUR_API_KEY with your Google API key. You can obtain it here https://developers.google.com/maps/documentation/javascript/get-api-key

To fix, the contact icons color issue, could you please try to apply the following CSS code through the Simple Custom CSS plugin or child theme’s style.css?

.perth_contact_info_widget span, 
.page-template-page_contact .contact-info span {
  color: #e93f33;
}

Regards,
Kharis

Hello Kharis,

i’m also using this template and i made this change in the header-contact.php but it does not work, is there any other hint?

Thanks
Ak

Hi Ak,

The latest version of Sydney Pro theme has its own route to enable the Google Map’s API key. You can enter it through Appearance > Customize > Sydney Pro: Extra options > Google Maps.

Regards,
Kharis

Hi Kharis,

thank you for your help, but i’m using Perth Pro and there is no extra options and the customizing part.
Any other idea?

Thanks

Hi,

i made the update today to the last version and now there is a option in the customzing part for google maps, i add there the API-Key but i still not see the maps on the frontpage, what else can cause this problem, any suggestions?

Thanks

Please try this plugin and see if it helps.

Regards,
Kharis

Hi,

thank you but this also don’t help :frowning:
Pls see here the result maybe u got another solution for it ==> http://demo.fanetwork.net/de/kontakt-anfrage-webdesign-anfrage-einholen/

Thanks

Hello there,

It’s displaying fine already as seen on the below screenshot. Have you been able to manage it?

Cloudup

Regards,
Kharis