Compatibility 4.8?

Hi for a new site I would like to use the theme Fashionistas. But I am a bit hesitant as on the theme page is says compatibility 4.5.
And the theme has not been updated in 2 years time. So I wonder if this is a wise thing to do.
So does this theme work with 4.8.x?
And are you still keeping the theme up tot date for future versions of WordPress (4.9 / 5.0)?
Or are you abandoning /phasing out this theme?

Hi,

I have tested the theme on WordPress version 4.8 and I didn’t saw any issues with it, but in case you will have compatibility issues, please let me know so I can check.

Kind Regards,
Csaba