Comments boxes not appearing

Hi,

I’ve checked the Screen Options-Discussion-Allow comments box on some of the pages on my blog (not all) but they’re not showing up. There is code about the comments in the page.php. Please can someone help - what else do I need to do to get the boxes showing?!

Thanks!

Hello there,

Please navigate to your page admin, click Screen Options in the top right corner:

…and check Discussion and Comments boxes. Then scroll down to Discussion section and check the Allow comments option. This should enable comment box on your page.

Also, make sure that you comments are allowed from WP admin > Settings > Discussion

I have tested comments on my end, and they are working just fine http://screencast.com/t/XNfKuAHNIf

If this is still no-go after that, you can try to disable all additional plugins because of possible plugin conflict.

All the Best!

Hi,

Thanks for your reply, but I’ve done all of that already and it’s not working. I’ve discovered that the comments show on a default or full width page, but not on a front page. Is there a way to enable them on a front page, or will I have to change all the pages/find a comments widget to enable them?

Thanks for any help!

Hello again,

That is additional info. Front page template is not loading comment because this option does not exist. This is intended. In case that you wish to enable comments on front page copy comments template code inside theme folder / page-templates / page_front-page.php - code below:

<?php
	if ( comments_open() || '0' != get_comments_number() ) :

		comments_template();

	endif;
?>

Insert that code just after the_content, like this http://screencast.com/t/qx0aUQER

All the Best!