Collapsed menu has a bit of a mind of its own

www.rworld.org.uk, hiddenfornow to get past the password.

The menu, when collapsed, seems to have a mind of its own, and clicking links doesn’t seem to actually select the link you want, especially when on a mobile device rather than emulating on a desktop machine.

Has something gone wrong that I’m missing?! Thanks in advance.

Hi,

Can you mention the name of the link that doesn’t work properly? So I can try it and quickly be able to identify the problem. So I can help with this in a better way.

Regards,
Kharis
aThemes Support

Video included. But hard as it doesn’t show clicks. When I click the top level links, you’ll see the page jumps up.

I then tried to click the “mental health first aid” link but got taken to the Events category.

Thanks.

Argh video won’t upload from phone. Try this: https://share.icloud.com/photos/0ESY6X-FqC_nh2XAHgIOElfSw

Another video. In this clip all I am trying to click is the “our donors” menu option. https://share.icloud.com/photos/0PIe6QTGrZ7QimMEc6fHjj_NA

Sorry to nudge on this but any help would be hugely appreciate. It has me stumped and I’m keen to launch the site if I can.

Hi,

Please try doing these steps:

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box
    ;(function($) {

      $('.main-navigation a[href="#"]').click(function(event) {
          event.stopPropagation();
      		event.preventDefault();
      });

    })(jQuery);
  1. Update

Regards,
Kharis
aThemes Support

HI Kharis, thanks for this. Annoyingly it hasn’t fixed things.

Can you just confirm the semicolon at the very start of the first line should be there? I have tried with and without.

Happy to provide WP / FTP details if it would help you with this oddity.

Hi,

To avoid the page jumping, please delete the # in your top level links and leave it empty. WordPress doesn’t allow an empty link when you first add your menu item but you’re free to remove it afterwards.

Thanks - but still not working. See this video of trying to click the “About R World” link.

Alright, I understand now. Use this plugin to send a temporary account for me at vlad[at]athemes.com, please. https://wordpress.org/plugins/temporary-login-without-password/

1 Like

Big thanks to Vlad for his help with this - now sorted.

1 Like