Change Speed of Testimonial Slider

Hello There.
How and exactly where can I change the speed of the testimonial Slider? The running is too fast, so you can not read the text.
Next Question: I currently use a Childtheme of Sydney. Do I need to change there, or in the original Sydney Theme?
Thank you for your help.
Greetings from Hamburg, Germany.
Ina.

Can nobody help? So i can not use the testimonials … :frowning: Do i need the pro-version of sydney therefor? please help… it`s really important…

Hi, sorry for the delay

you can change the speed of the testimonial carousel from js/main.min.js
you have to find (ctrl+f) this selector .roll-testimonials then change the value of the autoplay to 5000 for 5 second. see this picture for details http://prntscr.com/7wowl8

hi Awan… thanx alot but it doesn’t work…

i want seven seconds until next slide… i download the main.min.js and i set 7000 … and then upload back to js-folder in webspace…

is that right? or where is the mistake?

i have upload this in sydney theme and also in child theme…

I have tried and tested everything. There always remain only 3-4 seconds. I need at least 7 seconds, 8 or 9 are even better.

now i have set 5000 , and now there is no autoplay anymore :frowning: no the text ist stand still… :frowning: how i can change to autoplay back again?

by set 0 = 3-4 seconds slide

by set 5000 = it stands still, don’t slide anymore …

have anybody an other idea?

Uploading it in a child theme won’t do anything because the file needs to be enqueued.

  • open main.js, find what Awan said. Change the value to the one you need;
  • copy the contents, minify them with an online tool and then paste them (and replace) in the main.min.js (this one gets loaded, main.js is just for reference).
    Note that this isn’t update-proof.

this isn’t update -proof? it means, when sydney theme will received an update, THIS will NOT change?
In that case, it must not be in the child. then i change in parent theme.

but why the slider stands still, if i set 5000 im main.min.js? i have settings change like Awan wrote… he only wrote from main.min.js, not main.js

I am confused as to exactly where I need to change the now? I want that the slider remains 7 or 8 seconds so you can read the text correctly and then automatically switch to the next.

Vlad - regarding changing style of views, if I bought the Types Toolset would I be able to edit the styles of the different Types created in the theme (e.g speed of text, shape of image etc.)?

@tbs-admin: by the fact that it isn’t update-proof I meant that changes done in the parent theme files will be overwritten when the theme gets an update. That’s how the update system in WordPress works.

I don’t really now what you did but I suggest you re-install the theme and follow the steps I suggested above.

@simon.maddox: There isn’t any actual relation between Types (or any other of their products) and Sydney. We’re just recommending Types so users can quickly import the settings file and get the services/employees etc.

Thanks for the quick reply, Vlad.

Looking at the wp-types.com website, it looks like the (free) Types plugin is for defining back-end structures, while the (not free!) Views plugin allows creating and editing widgets etc. to display the Types. Just to confirm, are your Widgets hand-coded, or could they be edited by the Views plugin?

They’re hand coded and they’re built into the theme. I have no idea if the widgets or any other theme element can be edited with Views, I’ve never used it. But I assume it’s meant for creating new stuff rather then editing existing stuff.

Hi! I am having the same problem - I followed the steps to edit the js file, but it didn’t work. When I changed the speed to 5000, it stalled the slider completely.

Any help would be appreciated!

you have set the 5000 or another value WITHOUT the exclamation mark !!!

(".roll-testimonials").owlCarousel({navigation:!1,pagination:!0,responsive:!0,items:1,itemsDesktop:[3e3,1],itemsDesktopSmall:[1400,1],itemsTablet:[970,1],itemsTabletSmall:[600,1],itemsMobile:[360,1],touchDrag:!0,mouseDrag:!0,autoHeight:!0,autoPlay:11000})

Yes! That was it…thank you so much! :slight_smile:
Works perfectly now.
Love the theme.