Change employee URL path

Hi,

Is there a way to change the URL path for employee posts?

For example:

http://agac2016.conorg.com.au/employees/rosalind-croucher/

Needs to be:

http://agac2016.conorg.com.au/people/rosalind-croucher/

There’s a very good reason for this and quite simply people included as an “employee post” may not be an employee and would not want to be included in a URL implying that they are an employee, so as one of the keynote speakers, the last thing Professor Rosalind Croucher AM BA(Hons) LLB PhD AMusA FRSA FACLM(Hon) FAAL TEP would want to see in the URL to her bio is “employee”.

Using “people” in the URL would be the appropriate way to identify any sort of person wether an employee, members of a football team, a list of directors, committee members etc, etc.

Also, as there are only 2 keynote speakers for this conference I would want them centred on the page, and not left aligned is there a little bit of CSS I can use to fix this?

Thanks

Francois

Hello Francois,

  1. Please go to your Dashboard -> Types -> Post Types -> Employee -> change Slug from employees to people in Name and description section -> click Save Custom Post Type.

  2. Please try to use this CSS code to centre the items:

@media (min-width:992px){
    .team-item {
        width: 50% !important;
    }
}

.roll-team .team-inner {
    background-color: inherit !important;
}

.team-item img {
    border: white 5px solid;
}

You can add CSS code to style.css file of your child theme, also you can use Simple Custom CSS or similar plugin for adding CSS code.

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

P. S.
Actually, there is more simple way to center your employees. Just go to your Dashboard -> Pages -> Edit your front page -> Edit your Sydney FP: Employees widget -> check Center the employees checkbox -> click Done -> click Update.

Hi Roman,

Thank you for the initial quick response and your follow up.

I’ve seen that check box you refer to, which applies to the regular employee widget and not the type B widget, which is what I’m using, so your CSS mod works just fine – or rather it did because now the site is broken after changing the Employee post type slug name, have reverted it back to employee and as you can see from the site there are now no speakers!

More to follow shortly.

Francois

Hi Roman,

Based on your suggestion to change the slug name in the Employees custom field type from employee to people, I could in fact use any name – yes?

So I did and changed the slug name to speakers, saved the changes, refreshed the home page and both speakers have now vanished and they have gone from the conference page too.

So I changed the Employee Post Type slug name back to employee, refreshed the page – and nothing, the 2 speakers a still missing. I created a test page, added a new a row, inserted the employee widget type B, saved, refreshed page and nothing. The 2 speakers are still listed and viewable in the All Items, under Employees but they are missing from both pages

I’ve tried the modification on 2 other Sydney Pro sites and they too are now broken, after returning the Employee widget slug name back to employee.

Francois

Okay Francois,

I tried to replicate your issue on my localhost and I got the same result, Employees - Type B widget doesn’t work with custom slug of Employee post type. It looks like a bug, I have already reported it.

For now, please consider using regular Employees widget with custom slugs of Employee post type.

Kind Regards, Roman.

Hi Roman,

I made a mistake – the slug name is “employees” I had reverted it back to “employee” hence why it was still not showing the 2 speakers. The site now shows the 2 speakers based on the Employees Type B widget and centred with the use of your CSS.

I’ll leave it like that for now as the Type B widget is a better option for the site than the regular employee - the on mouse over overlay is a bit wrong, particularly as you can’t assign a URL to it, which you can click on to take you to the full employee post page.

So for now let’s hope that the page URL isn’t noticed.

I would still be eager for this to be fixed though, so as to have a more appropriate URL path.

I’ve just lost connectivity to my hosting provider and all my domains plus the AGAC2016 client site so for now I’m stuck.

Thanks for your help.

Francois

Hi Roman,

It’s been a while since my last post, so I thought it time to enquire how the bug fix for changing the slug name for the Type 2 employee widget is going.

Thanks

Francois

Hello Francois,

I have just checked it, unfortunately the situation is the same.

Kind Regards, Roman.

But will the issue be resolved though?

Hello Francois,

The issue should be resolved, but unfortunately I can’t tell you when.

Kind Regards, Roman.

I am also looking to rename the custom post types.

I cannot however find the options you mention (quoted below):

Please go to your Dashboard -> Types -> Post Types -> Employee -> change Slug from employees to people in Name and description section -> click Save Custom Post Type.

I am currently evaluating the free Sydney theme to ensure it can do everything we need it to do before purchasing Pro - is this a Pro feature or am I missing something?

Hello Cadellin,

Please check this:
http://docs.athemes.com/article/51-change-cpts-slugs

Kind Regards, Roman.