Change Blog Page language


#1

Hi there

I am preparing right now my homepage offline. Therefore I can’t provide you a link to the side.

But I assume my request is rather simple anyway…that’s probably why I didn’t find an answer on it using google search.

I would need all the blog page text (leave a comment, continue reading, leave a reply, comment) to have in german.

Where can I edit this?

Looking forward for your kind answer and keep up the nice work!


#2

Hi BBD,

First of all this is not a theme related issue and it is more like general query.

You can look for many plugins which are available in the repository. Personally I have used https://wordpress.org/plugins/codestyling-localization/ plugin a fewer times and has worked for me.

Thanks


#3

Hi Matty

Thanks for your answer and the link to the plugin. I installed the plugin but unfortunately it doesn’t work with this theme:

“Dies ist ein Problem in der Programmierung der Quelldateien, die Sie zu übersetzen versuchen. Kontaktieren Sie den Autor und erklären Sie das Problem.”

What this means is that there is an error in the sourcefiles. And that I would need to contact the author of the theme.


In any case what I did now is that I translated and created the german files .po and .mo by myself.

I placed them in the theme folder “lang”.

On wordpress if I go to settings -> general / I am now able to switch the language to german. But all the themes text stays in English :frowning:

Do I need to rewrite anything in a .php file?

For the future and other users it would be truly nice if this theme could get translated by code styling-localization. If you like I also can provide you the translations that I did.

Looking forward to your kind help!


#4

Thank you so much BBD.

I will ask the theme author to look into it.


#5

Hey BBD,

I just checked the plugin that Matty recommended and it seems to work fine with Fashionistas. I’m not seeing any errors.

Here is what I did:

  • added the new language (German) for Fashionistas in the plugin menu;
  • clicked rescan;
  • edit -> translated a string;
  • clicked Generate .mo file;
  • selected German from General > Settings.

#6

Hey Matty and Vlad

Thanks so much for your help. By doing it as you described Vlad it finally works!

You made my day.

Merci!

BBD


#7

I was now able to translate a couple of things but what I can’t find at the and of a page is the following:

  • Previous Article
  • Leave a Reply
  • Comment

Are this parts of your theme - can you find them yourself?

Thanks a lot for your support.


#8

No one?