Category Pages

I’ve set various categories for my posts. When viewing a post, I can see the associated category. However, when I click on the category to view other posts in the same category, I get a “Nothing Found” search box.

Hello there,

Try to flush your permalink. Go to Settings > Permalinks > then just hit the “Save Changes” button.

If it didn’t help, please try to switch temporarily to default WordPress theme. Then, let us know whether the issue remains.

Regards,
Kharis

Kharis - those didn’t work for me. any other ideas? I tried to add an example, but it isn’t letting me put links in the replies.

Hello there,

Thank you for updating me.

Could you confirm if the issue also happen with the default WordPress theme?

Regards,
Kharis

Kharis -

I used the theme twenty fifteen and am getting the same error. I guess the issue is with wordpress and not the theme then. :frowning:

Do you have any ideas or do I need to contact wordpress about this?

Thanks in advance,
Art

Dear Art,

Try to do one of the following:

  • Uninstall all non required plugins
  • Make a fresh WordPress install

If none of them helps, you should consult to WordPress community support forum.

Regards,
Kharis

Kharis -

Thanks for that feedback. I uninstalled the plugins we weren’t using and that did the work. I think it was the “types” plugin.

very much appreciate you sticking with me.

Art

Kharis -

I didn’t realize the “types” theme was a recommended plugin for Sydney, but after installing it I did receive this message:

“This theme recommends the following plugin: Types - Custom Fields and Custom Post Types Management”

so I reinstalled and activated it and the problem came back.

I still have it installed, but deactivated so that my category pages are working.

That said, I wanted to use the “clients” option that comes with the Types plugin to display our sponsor logos.

Any ideas? I have another plugin “Post Tags and Categories for Pages” that I’m using to add categories to my pages, which I need to be able to use the Post Grid plugin to display posts and pages in grids on the home page.

I tried deactivating the Post Categories for PAges plugin and activating the Types plugin and in this scenario my category pages still work so that conflict appears to be when both plugins (post tags for pages and Types) are activated that the conflict/problem is arising.

Thoughts?

Art

Dear Art,

I would like to apologize in advance for responding slowly.

What will happen if you completely delete the Types plugin then install and activate it through Dashboard > Plugins > Add New > Search “Types” > Install > Activate.

If the issue didn’t get resolved, could you please give me a temporary access to your site admin area so I can have a closer look? You can send the login credentials to my email kharisblank at gmail dotcom with the link to this topic.

Regards,
Kharis

Kharis -

I deactivated and reinstalled Types and the Post Tags for Pages plugins and they are still conflicting. I found a way around needing to tag my pages so I’m okay, but wanted to let you know. if you still want access for troubleshooting for future folks that might need the page category plugins I’m happy to share login credentials just let me know. sorry for the delay in my reply.

Art

Actually I found a different plug to add the category to pages that doesn’t seem to conflict. For others that need this ability the plugin I found to work is Add Category to Pages

Thanks for all your help and patience Kharis.

Dear Art,

Thank you for updating me.

I’m glad to know that you have been able to resolve it by yourself.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis