Can't Post Comments New Topic

Posts where there already ARE comments visitors can add more. Example:

https://www.columbussquaredance.com/2020/06/28/harry-packer/

Posts where there are NO comments . . . no place to add a comment: Example:

https://www.columbussquaredance.com/2020/06/27/lloyd-sparky-sparks/

Under Settings > Discussion the option to “Allow people to submit comments on new posts” is checked.

Please advise.

Hello there,

Please check whether you have enabled the ‘Allow comments’ option on each post level under the post editing screen > Discussion.

Regards,
Kharis
aThemes Support

Thank you for sharing the screenshot.

I meant, Dashboard > Posts > edit one post > Discusson.

Screen Shot 2020-09-06 at 19.46.16

Regards,
Kharis
aThemes Support

Try flushing the site caching enabled on your site. Then clear the cache, history, or cookie on your web browser before reloading your post page.

Regards,
Kharis
aThemes Support

I have tried that multiple times. With multiple / different browsers. Cleared all cache from Cloudflare, my ISP, and at the site level. It doesn’t change anything. For example:

https://www.columbussquaredance.com/2020/08/07/glen-thomson/

There is no comment box.

Thank you for your assistance.

What will happen if you choose the default template? I am curious it is a specific issue with current post template.

Regards,
Kharis
aThemes Support

Same results. On any post that already has comments, there’s a “Leave A Reply” comment box. On any post which has no comments, there’s no way to put a comment.

Creating a new post doesn’t fix it, either. New posts have no comment box.

I even edited single.php from this:

		<?php
			// If comments are open or we have at least one comment, load up the comment template
			if ( comments_open() || get_comments_number() ) :
				comments_template();
			endif;
		?>

To:

		<?php
				comments_template();
		?>

And changed No sidebar Page Template (post-templates/post_nosidebar.php) from:

			// If comments are open or we have at least one comment, load up the comment template
			if ( comments_open() || get_comments_number() ) :
				comments_template();
			endif;

To:
comments_template();

And still there is no comment box for new postings.

Hello there,

As checked from your site’s dashboard, it seems likely you are getting plugin conflict with Webcraftic Disable Comments. Please try disable it temporarily, clear cache, and run your test.

Regards,
Kharis
aThemes Support

Disabled plugin. In fact, I disabled ALL the comment related plugins. (I’ve done this multiple times already.)

Cleared Cache at Cloudflare level.
Cleared cache at ISP level.
Cleared cache at website level.
Cleared cache on four different browsers on three different devices.

Added new posts. Looked at old posts.

There is no comment boxes on new postings.

Would DEARLY love to upgrade to Sydney PRO to see if THOSE comments work, but this installation ALSO won’t let me add a new template.

All of this started when Sydney was last updated.

Kharis, you logged into the site. When you did so, were you able to get comments to work?

I just replied your email. And now you are having an email reply waiting your response.

Let me know if you haven’ yet received it.

Regards,
Kharis
aThemes Support