Can't import demo content

Hi,

I really like the Sydney theme. I can successfully import settings, but when I use Wordpress importer to import the demo content, I just get a blank screen. I first tried on WP 4.4.1, then downgraded to 4.1.1 (which seems to be the version the demo content is generated), it still doesn’t work. I stepped through the importer code a bit, but it seems the parser can’t parse the xml file.

Am I doing something wrong? I am happy to share the site login, etc. It’s just an empty WP install right now.

Many thanks!

NM this solved the problem :

yum -y install php-devel php php-common php-gd php-mcrypt php-mhash php-xml php-xmlrpc php-domxml php-gd php-mbstring php-mysql php-ncurses php-pear

service php-fpm restart

thanks to: https://community.theme.co/forums/topic/unable-to-upload-demo-content-xml/page/2/

Hello @bbpro,

It’s great that you figured it out by yourself and thank you for sharing a solution of your issue!

Please feel free to ask any other questions that you might have in future.

Kind Regards, Roman.

Hello @bbpro, hello Roman,

would one of you be so kind and translate the solution into a more user friendly language? I am experiencing the same issue importing the sydney-demo-content.
In other words, even trying hard, I can’t identify what you mean by:


NM this solved the problem :

yum -y install php-devel php php-common php-gd php-mcrypt php-mhash php-xml php-xmlrpc php-domxml php-gd php-mbstring php-mysql php-ncurses php-pear

service php-fpm restart


THANK YOU

Hello @id,

That is command for the server’s Linux Terminal. To be more exact, for Yum package-management utility that is used by such distributions as Red Hat Enterprise Linux, Fedora, CentOS. If your server is not using such distribution, that command will not help.

So I kindly suggest you to contact your hosting provider regarding this issue.

I really hope that it will help you.

Kind Regards, Roman.

Hello @Roman,

many thanks for your reply. Unfortunately, this is not gonna be my solution to the issue.

In my case, it seems more like “session expired” problem or, too much data to “Download and Import file attachments”. Getting message:


Sorry, there has been an error.
File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.


Any idea which php.ini file may it be? I was unable to identify it.

Is there any way to use FTP server to “Download and Import” sydney-demo-content?
Is there any way to do it manually?

THANK YOU AGAIN

Okay @id,

I think that you have to increase the value of your upload_max_filesize property in php.ini file.

Here is good tutorial on this topic, but please note that it’s for Bluehost.

Kind Regards, Roman.

P. S.
It is better to create your own topic for your question to keep forum in good order (and add links to relevant topics there).

Thank you Roman for re-directing my attention.

I will now try to implement your recommended solution to my free 000webhost.

The point is, importing the sydney-demo-content worked fine, first. Now it’s not.

Great template btw.

Thank you.

You are welcome @id,

It would be nice if you leave your feedback for Sydney theme at WordPress.org, here is a quick link :slight_smile:

Have a nice day!

Kind Regards, Roman.

Done.

A nice day to you, too.

ps. Hope to find the solution soon. Otherwise, I will set up a new topic as suggested :wink:

Thank you very much! :wink: