Can't get heading on posts page to display

Is there a setting somewhere to turn on/off the heading displayed on the posts page? The headings for all other pages display just fine–but it is consistently missing on the posts page. And it’s a post-page-specific issue: If I go to the Static Front Page settings and change the posts page to a different page, just as a test, the heading for that page will disappear . . . until I make it not the posts page. Is there a setting somewhere that I’m missing?

Hello @susanp,

Nope, there is no such setting, blog page doesn’t have title by default. Please try to use the following CSS code in order to add title to your blog page.

You can add CSS code in DashboardAppearanceCustomizeAdditional CSS (WordPress 4.7 and up). Also you can add CSS code directly to style.css file of your child theme.

body.blog div#primary::before {
    content: 'Blog';
    margin-left: 60px;
    font-size: 36px;
    color: #272727;
    font-family: 'Josefin Sans', sans-serif;
}

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

That worked perfectly! Thank you, Roman!

Cheers -
Susan

Great! You are welcome Susan :slight_smile:

Kind Regards, Roman.