Can't change menu font - tried various code in css nothing works

Hello,

I’ve searched the forum and web extensively and tried various solutions but I cannot get the menu font to change to a google font.

I used the code:

#mainnav ul li a {
  font-family: "Arial Black", sans-serif;
}

Which works and changes the menu to Arial but when I substitute:

#mainnav ul li a {
  font-family: "Press Start 2P", cursive;
}

It does not load the font. However, if I change the header font in the customize menu to Press Start 2P font is changes the header and menu font. I would only like to change the menu font.

Thanks,
E

Hello, try to use the following CSS code.

You can add CSS code in Customize → Additional CSS section.

@import url('https://fonts.googleapis.com/css?family=Press+Start+2P');
#masthead .mainnav ul li a {
    font-family: 'Press Start 2P', cursive !important;
}

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

Excellent thank you. Just a note for anyone having the same problem, the code must be added in the first line of the css otherwise, it gives an error that @import is not allowed here.

You are welcome!

And thanks for the useful note :slight_smile:

Kind Regards, Roman.