Cannot save changes with elementor anymore: 500 internal server error

No changes can be saved with elementor since yesterday. I have already:

  1. checked everything with my provider,
  2. deactivated the last plugin for advanced translation as well as wpml media,
  3. increased max memory to 512M so that there are no red flags under support mentioned with 40M anymore,
  4. changed to wpml classic editor again
  5. also contected wpml, they said I have to upload the latest version, but I have installed the latest version 4.4.11 of WPML first, then I got the error alert that I need the prior version 4.4.10, which I installed and this first error was gone.

I could edit and save all changes before the advanced translater which I deactivated then. Could you please have a direct look at it? I am sure for you it is just a minute. Just send me a private message so I can provide you access to our website. THX

Hi,

I am sorry to hear that you’ve been into such this issue. I am happy to help out.

I am not sure this issue is caused by Airi theme’s code. To confirm this, can you try temporarily disabling the Airi theme and run your test? To do this privately, I’d recommend enabling troubleshooting mode with the help of this plugin.

Let me know how it goes.

Regards,
Kharis
aThemes Support

Thanks for your reply, Kharis! I already saw your plugin recommendation in other posts before. Do you have any other recommendations? Or could someone from your side just have short look at our website? That would be super helpful.

Hi,

Thank you for getting back.

Sure, I’ll be happy for inspecting it directly from your website’s admin area.

Please share a temporary admin login link to my email at kharis@athemes.com, that you can generate with this plugin. Ensure the link expiry is set to 7 days and all admin rights are enabled.

Adding, to help me quickly find you in my inbox, please attach the link to this topic in your email body.

Regards,
Kharis
aThemes Support

1 Like

Thank you for the link of this cool plugin, Kharis! I will use it as standard plugin also for our future website projects to share access with others :pray: Now I am super curious how this problem can be solved…

Best regards from the WPML support team: The following error is what comes up when trying to translate with the Theme activated

1 Fatal error: Uncaught TypeError: Argument 1 passed to WPML\PB\Config\Hooks::extendTranslatableWidgets() must be of the type array , null given, called in / var /www/sites/old-cuatro/wp-includes/ class -wp-hook.php on line 303 and defined in / var /www/sites/old-cuatro/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/Config/Hooks.php:44 Stack trace: #0 / var /www/sites/old-cuatro/wp-includes/ class -wp-hook.php(303): WPML\PB\Config\Hooks->extendTranslatableWidgets() #1 / var /www/sites/old-cuatro/wp-includes/plugin.php(189): WP_Hook->apply_filters() #2 / var /www/sites/old-cuatro/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/ class -wpml-elementor-translatable-nodes.php(952): apply_filters() #3 / var /www/sites/old-cuatro/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/ class -wpml-elementor-translatable-nodes.php(30): WPML_Elementor_Translatable_Nodes->initialize_nodes_to_translate() #4 / var /www/sites/old-cuatro/wp-content/plugins/sitepres in / var /www/sites/old-cuatro/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/Config/Hooks.php on line 44

Deactivating the theme and switching to a standard WP theme seems to resolve it.

If possible, I’d suggest reaching out to their support (what I am doing right now :wink:) and letting them know about this as it looks like they have been actively trying to make their theme compatible with WPML.

Also, as they are not officially compatible with WPML they can contact our team directly through our go global program to help them become compatible

I think that is also good for you and future clients to solve this problem and become an offically compatible partner with WPML :woman_technologist:t5: