Can not change blog url

Hi there,

My page is called: www.faaflerepaaditnyhedsbrev.dk
I just made a blog with a few new posts. Unfortunately If I go to the blog page and press on one of the posts, I will end up at my starting page.

When I go to the posts in the control panel, I see that the url being connected is my starting page, but the button, where I usually can change the url is gone.

Can you help me on how to make my button appear again, so that I can change the url and my blog posts will show?

Thanks
Maj

Hi,

Please try to deactivate all your plugins and then check how it works, also, please make sure the permalinks of the posts to don’t have special characters and also t not be modified to redirect to homepage.

Best Regards,
Csaba

Hi Csaba.

If I deactivate my plugins and activate them again, will I loose any data?
Where do I check if the permalink redirect to my homepage? Usually there is an ‘edith’ button next to the link/ url, but in my blog posts it automaticly sets the url to my startpage and there is no button to change it.

Thanks, Maj

Hi,

You can change the URL of the Blog Posts, but all of them are linked to homepage? Please chack that too. By deactivating plugins you will not loos any data.

Best Regards,
Csaba

Hi Csaba,

I not deactivated all plugins. Nothing new unfortunately. Activated them all again and still nothing.
I am not able to change the URL of the blog post. The link is set to my homepage and there is no button to change it.

I really hope you can help,

Thanks,
Maj

Hi,

Please deactivate your plugins and then check how it works, with no plugins active, don’t just deactivate and reactivate, that way you can’t check which plugin is causing the problem if it’s caused by a plugin.

You can edit the Post links in wp-admin > Posts - Edit a post and under the title there is the link of that post and after that there is an “Edit” button.

Best Regards,
Csaba

Hi Csaba.

Thank you for your help.
I did both already and it still didn’t work.

Luckily I found a solution seaching on the internet. I am going to copy it here, so if anyone else has the same problem, they can follow these steps. It worked for me ?

Cheers,
Maj

The following is copied from: http://support.hostgator.com/articles/specialized-help/technical/wordpress/links-on-wordpress-all-redirect-back-to-home-page

“Sometimes, changes made to the .htaccess file can cause WordPress to redirect all links back to the home page instead of showing the page requested. In some cases, resetting the permalinks within WordPress will resolve this issue.

To reset the permalinks for your WordPress installation:

Log into the WordPress Dashboard.
In the side panel, go to Settings > Permalinks.
Make note of the current setting. (If you are using a custom structure, copy or save the custom structure somewhere.)
Select the Default option.
Click Save Changes.
Now select the previous setting you had before Default was selected.
Click Save Changes.

This will reset the permalinks and will most likely fix the issue.”

Hi,

Great! I’m glad it’s resolved! If you need help with anything else, please open a new topic.

Have a nice day!

Best Regards,
Csaba