Call to actions displaying the same on each page

Hey guys, I am building a site on taurangadjs.co.nz however it has a Coming Soon page at current.
I am using Site Origin page builder to build this site.

I am building it for a DJ company. I have made a page called Wedding DJ and a page called School Ball DJ.

I have copied the page builder layout to save me building it all again one each page.
When I change the call to action data it changes it on both pages. For example on the Wedding DJ page the call to action is meant to say “View our recent wedding testimonials”.
The School Ball DJ page is meant to say “Get your FREE quote today!”.
When I save the call to action on the wedding testimonials page it also says “View our recent wedding testimonials” on the School Ball DJ page.

When going in to Edit Page the data displays all correctly.
It just doesn’t display correctly on the page.

I have tried to delete the call to action and create a new one the same however it still changes the call to action on both pages.

Tried to explain best I could :slight_smile:
Would anybody know how to fix this?
Any help would be greatly appreciated!

Cheers,
Ollie.

Hi Ollie,

I’m facing the similar issue with my website : http://www.edulambda.com. I have tried all possible step. Still, no help. Please let me know the steps followed after your issue gets fixed.

Regards,
Rohan Arora

Hi,

I’ve just tried this on our demo page and it doesn’t seem to happen: http://demo.athemes.com/sydney/testing/
I’ve copied the layout and then modified the call to action data.

Can either of you send me an admin account to vlad[at]athemes.com so I can have a look?

I have sent the admin details through to your e-mail.
Thanks Vlad, appreciate the help.
Cheers,
Ollie.

@rhnarora84: We’ve identified the issue on Ollie’s website to be caused by W3 Total Cache. If you’re running this plugin, clear the cache from all modules/disable the plugin and have a look please.