Calendar Events not displaying properly

Hi

I have a Calendar one of my websites (https://www.bstai.ie) which was working fine, but now when I click on the event, it does not display correctly and basically does not work. I am using Events Calendar and thought that perhaps it was that, so I contacted their support but they couldn’t see anything. I contacted my hosting company and they suggested disabling plugins, etc. I did all this and nothing fixed it. The events can be added fine, show up on the News page and Calendar fine, but when clicked upon, they show a strange summary text version of the page which doesn’t function.

Eventually I went to where I have kept the draft (http://www.herrflynn.com/wordpress) went through everything again (disabled all plugins, deleting some even) and no success. Being a bit inexperienced, I was very afraid to go back to the basic Twenty Seventeen theme, but had to try and see what would happen. The Calendar worked fine, displaying the individual event pages fine again.

So it looks like it is the Sydney Pro Theme - that is the only thing I can conclude.

Any help solving the issue would be greatly appreciated. The group (bstai.ie) are delighted with their lovely, new, fresh, modern website, so I want to try to have the events displaying properly as soon as possible (they have a conference coming up too and will be using Eventbrite very soon for their tickets, hence the urgency to get everything fixed).

Thank you in advance.

Tommy

Screenshots of same event in Twenty Seventeen (correct) and Sydney:
2017theme SydneyTheme

Hello Tommy,

I’ve just tried to recreate this issue on my local Sydney Pro theme install, but I couldn’t, an event page looks okay. I would like to check your event page without additional plugins activated, so can you please deactivate all your plugins except Sydney Toolbox and Elementor, and leave here a note?

Kind Regards, Roman.
aThemes Support

Hi Roman
Thanks so much for getting back to me. I turned off all plugins as suggested but the problem is persisting.

Attaching screenshots of the plugins deactivated and the event still not displaying.
event_single plugins

It looks like you have activated everything back. Can you please deactivate plugins and let me check your site? Screenshots are not enough, I want to check the page code.

Kind Regards, Roman.
aThemes Support

Hi Roman

I deactivated everything on the draft site http://www.herrflyyn.com/wordpress as I didn’t want to do anything on the live site .

Everything should still be deactivated there.

Thank you again.

Tommy

Hello Tommy,

Strange, it looks like your events have incorrect ID (it’s 0 in every event that I checked). So can you please try to delete all your events and create them from scratch with additional plugins deactivated?

Kind Regards, Roman.
aThemes Support

Hi again

I deleted all the other events and created one from scratch but still no luck unfortunately!

Again, thank you so much for your assistance.

Tommy

events_tryout

Hello Tommy,

Please make sure that your server meets WordPress requirements:

Also you can try to rebuild your website in a staging environment or locally and see if it works as it should (then you will be able to move rebuilt website to production environment). Here are helpful tutorials:


Kind Regards, Roman.
aThemes Support

Hi again Roman

I was nearly having a heart attack when you suggested re-building the site - it took me a month to do the present one! Also I already was using the draft site for testing everything.

Anyway, I have spent the evening trying out different things on the main website (not the draft) wth all the plugins activated, and eventually went back to the Events Calendar settings. I had selected Elementor Full Width for the Events template. I changed this to just “Full Width” and it worked!

So it looks like The Sydney Pro template and Elementor have some clash with the Events Calendar. Hope this helps you and support for the future.

Thanks again for all the help and assistance. I am delighted that my website is back working correctly in all areas. My next step is to go back and fix all the things that seem to be making it a bit slow (I feel). I used GT Metrix and found their analysis really good - my next task now is to try and figure it all out!!

Kind regards

Tommy

Hello Tommy,

Thank you for sharing that, I’ll add it to our list.

Kind Regards, Roman.
aThemes Support