Button Hover Colors


#1

Hi,

I just upgraded to Sydney Pro.

With Sydney (free), I was able to edit the CSS to change the hover color, border, and text size for each button on my site (header slider button and a “submit” button).

However with Sydney Pro, the same CSS additions are not affecting the buttons, and after many attempts, I cannot seem to alter any of the HOVER functions of the buttons.

What CSS code do i need to add to alter elements of the buttons when HOVER is activated?

Thanks!


#2

Hello there,

Thank you for getting in touch.

I would be happy to take care of this for you, I just need to replicate your CSS code. Could you please post it here?

Regards,
Kharis


#3

Thanks a bunch Kharis.

I believe you mean the CSS that I used for Sydney Free. Here it is:

.roll-button:hover {
border: 2px solid #fff;
font-size: 17px;
color: #ffffff !important;
}

button:hover,
input[type=“button”]:hover,
input[type=“reset”]:hover,
input[type=“submit”]:hover {
border: 2px solid #fff;
font-size: 17px;
color: #ffffff !important;
}

Thanks again.


#4

Hello there,

Could you please try the following?

button:hover,
input[type=”button”]:hover,
input[type=”reset”]:hover,
input[type=”submit”]:hover,
a.roll-button:hover{
  border: 2px solid #fff !important;
  font-size: 17px !important;
  color: #ffffff !important;
}

Let me know how it works for you.

Warmest regards,
Kharis


#5

Thanks Kharis,

But unfortunately that didn’t work. :frowning:


#6

Hello there,

Thank you for reporting.

Probably the browser’s and/or site’s cache can’t read the changes you have made. Could you please try to do the following?

  • Clear your browser’s cache
  • Clear your site’s cache if you have a cache plugin like W3 Total Cache has being activated

Let me know how it goes. I’ll wait to hear back from you regarding your stats.

Warmest regards,
Kharis


#7

I cleared the cache of my browser (Chrome) from the beginning of time.
I do not have a cache plugin like you mentioned.

I restarted my computer, made sure I still had the exact same CSS code that you gave me at the bottom of the Stylesheet, and restarted my computer, but still doesn’t work. :confused:

Thanks for the very rapid support, Kharis.


#8

Hello there,

Thank you for reporting.

I would be happy to take care of this for you. I thought I should inspect your site directly. Could you please post your URL here so I can have a closer look?

Warmest regards,
Kharis


#9

Sure thing.

Here is the URL: http://zachwillason.com/

Thanks for the help Kharis!


#10

Kharis!!!

I don’t believe you were able to do anything without logging into my wordpress account, but I have good news…

All of the sudden the changes I made for my buttons work!!! :smiley:

So this issue is officially resolved! (for now) haha

Thanks again man.


#11

Hello there,

I would like to apologize in advance for replying slowly.

I’m glad that it has worked already.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

I’m happy to have an opportunity to assist you.

Warmest regards,
Kharis