Bug issue

Hi. My website www.elpablocs.be viewed on iPad mini, has this issue of the Project counter and testimonials section: http://prntscr.com/ez7hjp - http://prntscr.com/ez7hry - http://prntscr.com/ez7i06. Can you resolve this issue please?

Kind regards,

Pieter

Hello;
I also have the same problem (just only on iPad Mini).
I Use Sydney FP: facts widget and the statistics that shows on iPad Mini’s screen is the same as Pieter’s.
This just started to happen after I rolled back PageBuilder from 2.5 to 2.4.25
It would be nice to have your advice to fix it.
Best regards,
Nabhaporn

Hello there,

Please try to follow these steps:

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box

;(function($) {

  'use strict'

  var container = $('.widget_sydney_testimonials').parents('.panel-row-style');

  if( $('.widget_sydney_testimonials').length && container.hasClass('siteorigin-panels-stretch') ){
    
    $(window).on('load resize', function() {

      if ( matchMedia( 'only screen and (max-width: 980px)' ).matches ) {

        var owlItem = $('.widget_sydney_testimonials .owl-item').width();

        $('.widget_sydney_testimonials').width(owlItem).css({
          'margin-left': 'auto',
          'margin-right': 'auto'
        });
        
        $('.widget_sydney_testimonials').find('.col-md-12').css({
          'padding-left': 0,
          'padding-right': 0
        });

      }

    });  

  }

})(jQuery); 

  1. Update

Let me know how it goes.

Regards,
Kharis

Hello Kharis;
Thanks so much for your answer.
First off, I have zero knowledge about JavaScript. So I’ll get frustrated with this kind of things.
I did not use the Sydney FP: Testimonials widget. I only used Sydney FP: facts widget.
My problem on iPad Mini’s screen is the same as Pieter’s http://prntscr.com/ez7hjp
Please kindly advise.
Best regards,
Nabhaporn

Hello @nabhaporn,

Do you have other active plugins? If so, please temporarily deactivate them, and then reload your site.

Regards,
Kharis

Hi Kharis,

the javascript did not do the trick, but by deactivating my plugins, the issue with the testimonial slider is fixed. So only the issue with the facts section remains. Any other suggestions?

Kind regards,

Pieter.

Hello Pieter,

Do you have other active non-required plugins? What will happen if you temporarily disable them at once, then check your facts. Can you find this issue to happen on our demo site as well?

Regards,
Kharis

Hello Kharis;
Thank you so much for your reply.
I just had a chance to log in my dashboard yesterday after reading that Pieter’s problem (like mine) still remains.
5 minutes ago, I’ve already checked Sydney demo site on my iPad Mini. There is also the same problem of the Facts issue. It is exactly the same as my website and also Pieter’s.
Best regards,
Nabhaporn

Hello there,

Could you please confirm if your web browser is the latest version?

Regards,
Kharis

Hi Kharis,

I disabled every plugin one by one, and the result was still the same. Also I checked your demo site, and like Nabhaporn said, the same issue remains.

I also check my website on Google Chrome browser, and the same issue there.

I’m quite sure I have the latest version of my browser. I always do the necessary updates.

Regards,
Pieter

Hello Pieter,

I am really sorry, I can’t debug this trouble immediately as I don’t have an iPad mini device. Meanwhile, you can disable the counter animation and let it be a static number instead. Please follow the below steps:

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box

jQuery(function($) {

  $('.roll-counter .numb-count').each(function() {

    var val = $(this).attr('data-to');
    $(this).attr('data-from', val);
    
  });

});

  1. Update

Regards,
Kharis

Hi Kharis;

The “counter animation” is pretty awesome so I still keep it that way even though it doesn’t look good on my iPad Mini.

Last night, when I had checked my website on iPad, the “Facts issue” disappeared. It was going back to normal. I’ve waited until this morning and double-check it again. It’s still normal. I really don’t know why, it’s good though.

But when I checked the Sydney demo site, the Facts issue still remains. Perhaps Pieter might want to check with his iPad Mini too.

I really appreciate your patience and your support. Thanks.

Bye.
Nabhaporn

Hi there,

I am really sorry for this trouble. I’ve discussed about this with our developer. He’ll disable decimal or something else to address this issue. It might be available on the next update. I can’t tell you when it’ll be completed, since he hasn’t had an ETA yet, please be patience.

Regards,
Kharis

Hi,

for now it works fine for me.

Thanks for your help,

Kind regards,
Pieter

Hi Kharis;

Good news! Just now, when viewing Sydney demo site on my iPad Mini, the counter animation is working properly.

No more trouble with the Facts Issue (both my site and demo site). I really don’t know why (again).

Thanks so much, Kharis.
Nabhaporn