Broken links in projects

I have an issue with my projects. I see that there is an option to for a different url but the settings say “Leave it empty and it will default to its own page”.
However, when I click on a project, even from the permalink on the Wordpress editor page, I get a 404.
What am I missing?29![38|690x298]

I don’t know how I solved it, but now it works.
What I did:
went to the permalinks settings and clicked on “save” even if I didn’t change anything.
unistalled a portfolio plugin which I was not using (I don’t think this was messing with the permalinks, though).

Hello there,

went to the permalinks settings and clicked on “save” even if I didn’t change anything.

Technically that’s a way of flushing permalink structure. It tells WordPress system to listen new permalink structure from new registered post type like projects.

I am closing this ticked. Feel free to open a new topic if you have any other questions to ask.

Regards,
Kharis