Blog post won't show - turns to front page instead

Hi there,

My website is www.faaflerepaaditnyhedsbrev.dk

Unfortunately my blog won’t work. When I click at one of my blog posts I am being sent to the front page instead of the blog post.

Can you guys help me?

Thanks,
Maj

Hello Maj,

Please try to temporarily deactivate all your plugins except Sydney Toolbox and Page Builder by SiteOrigin, and see if it helps.

Kind Regards, Roman.

Hi Roman,

Thanks for your fast reply.

I deactived all plugins except the two you mentioned, but the blog still didn’t work. Afterwards I activated all plugins again and it was still the same.

Do you have another idea what is wrong?

Thanks,
Maj

Hello Maj,

It looks like this issue requires close inspection, this goes beyond our support policy.

As an option, you can find a reputable freelancer on Upwork for this kind of service.

Kind Regards, Roman.

Hi Roman,

Thank you for your help. I’ve been seaching further on the internet and luckily I found a solution. I am going to copy it here, so if anyone else has the same problem, they can follow these steps. It worked for me :slight_smile:

Maj

The following is copied from: http://support.hostgator.com/articles/specialized-help/technical/wordpress/links-on-wordpress-all-redirect-back-to-home-page

"Sometimes, changes made to the .htaccess file can cause WordPress to redirect all links back to the home page instead of showing the page requested. In some cases, resetting the permalinks within WordPress will resolve this issue.

To reset the permalinks for your WordPress installation:

Log into the WordPress Dashboard.
In the side panel, go to Settings > Permalinks.
Make note of the current setting. (If you are using a custom structure, copy or save the custom structure somewhere.)
Select the Default option.
Click Save Changes.
Now select the previous setting you had before Default was selected.
Click Save Changes.

This will reset the permalinks and will most likely fix the issue."

You are welcome Maj!

And thank you for sharing a solution :slight_smile:

Kind Regards, Roman.