Blog Page Title Won't Display

I cannot get the blog page to display the title I have given it. Is there a setting for this? I have looked through my CSS and it doesn’t seem like I written code to hide the title and forgotten about it.

Hello @davidtong,

Please check this topic:

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

Is there any way to make the spacing look identical to that of other pages? Right now there is no margin on the top, and a light gray line on the bottom. I want the pages of this website to be consistent.

I added

display: block;
margin-top: 45px;

However, this does not work for tablet and mobile.

@davidtong, please provide a link to your blog page.

Kind Regards, Roman.

Unfortunately, I’m hosting the site locally right now.

@davidtong, please try to use the following CSS code.

You can add CSS code in Dashboard → Appearance → Customize → Additional CSS (WordPress 4.7 and up).

body.blog div#primary::before {
    content: 'Blog';
    margin-left: 60px;
    font-size: 36px;
    color: #272727;
    font-family: 'Josefin Sans', sans-serif;
    margin-top: 60px;
    display: block;
}

body.blog div#primary .hentry {
    border-top: none;
}

Kind Regards, Roman.

Thank you for your timely response. It seems that it is still incompatible with formats other than desktop. Please make this response private.

See:

http://imgur.com/DQv2qSG
vs.
http://imgur.com/7ib9AEK

It looks like this issue requires some coding and testing on different screen resolutions, this goes beyond our support policy. It’s considered advanced customization. As an option, you can find a reputable freelancer on Upwork for this kind of service.

Kind Regards, Roman.