Blog excerpt length not working

Hi,

I have set the excerpt length to 40 through the “Blog options” in the customizer. It works well in my first language, but it doesn’t in all translated posts…

Hello @chuchubbbb3,

I will be glad to help you, but can you please provide more details about your issue?

Kind Regards, Roman.

Hi,

Blog excerpt problem 1(with excerpt)
Blog excerpt problem2 (without excerpt)

In the first picture, you can see […] at the end of the words. But ,for the second picture, the entire article comes out instead of […} at the end. Hope you understand my problem with the pictures. Very appreciate your help!

Hello @chuchubbbb3,

Can you please use your WordPress Media Library or another screenshot service to show screenshots?

Kind Regards, Roman.

My website still in my localhost. What do you mean by another screenshot service? Any suggestion?

You can use something like snag.gy

Kind Regards, Roman.

Please see if it is ok for you. Thanks!

Yep, it’s great.

Can you please try to activate default Twenty Sixteen theme and see if it helps?

Kind Regards, Roman.

Hi,

I have activated the default Twenty Sixteen theme. I think it doesn’t work. After activating the default Twenty Sixteen theme, what I can see is this: https://snag.gy/pNz2Hg.jpg and some words under the picture. The words haven’t excerpt to 40 words which I required. Instead, it still shows the entire article. The problem is unsolved. Please help! Many thanks for your continuous support!

Hello @chuchubbbb3,

It looks like translation plugin issue.

Can you please contact plugin support and see what they say?

Kind Regards, Roman.

Hi Roman,

As I don’t have an wordpress.org account, I cannot ask questions there. But I have found another way to solve the problem finally.

However, I have another problem want your support. Is it possible to align the topic with the photo? Please see: https://snag.gy/ErMHsh.jpg. And what I want is this: https://snag.gy/glwQk9.jpg

One more thing, can I change the […] which can be found in the preview of the blog post to a button with the text of “continue reading”?

Hello @chuchubbbb3,

  1. That images are aligned in Sydney by default, so I can’t tell you something specific.

  2. Please check this solution, just replace Read More with Continue Reading.

Kind Regards, Roman.

Hi Roman,

The second solution works like a charm! Thank you so much! For the first one, I hope someday you and your team will make this option available in the “Customizer” so that people can change it freely by ourselves. Anyway, thanks so much for your continuous support! Your help is changing the world.

You are welcome @chuchubbbb3!

Thank you for the kind words, and have a nice day :slight_smile:

Kind Regards, Roman.

Oh, I have encountered a new problem. Sorry for bordering you again. My problem is I would like to translate the “continue reading” to another language, but I don’t know how to do that. Please show me again your magic power!

Hello @chuchubbbb3,

Did you try to translate it in the code from the topic above?

Kind Regards, Roman.

Hi Roman,
The above topic? You mean the link of “read more” you previously provided to me?

I am not sure I can find an answer from that topic about how to translate the “read more”.Can you explain a bit more, please?

Hello Roman,

Did I describe my problem clear enough? I am afraid you are not understanding my question because of my unskillful English and therefore no reply to me.

I still have this translation problem and don’t know how to tackle it. Could you please offer me a bit more support? Thanks!

Hello @chuchubbbb3,

I mean, if you used this code:

function new_excerpt_more($more) {
    global $post;
    return '<a class="moretag" href="'. get_permalink($post->ID) . '"> Read More</a>';
}
add_filter('excerpt_more', 'new_excerpt_more');

…then please just try to replace Read More with translated phrase.

Kind Regards, Roman.

Ok. It works, but not perfectly. When I replace the “read more” with the translated phrase, both languages of the blog will be changed to that translated phrase. And I want to use “read more” in my English blog, and use the translated phrase in my translated blog.

How can I do this?