Blank Space above footer

Hi,

Thank you for the great theme !

Works perfectly fine except for a blank space above the footer.

Impossible to remove it with padding and row margin tool (only reduce it)

You can see the site here http://www.so-fetch.fr

Please let me know if you know how to fix it.

Best Regards,

Michael

Hello Michael,

Can you please try to use Front Page template instead of Full width?

Kind Regards, Roman.

Hi Roman,

Thank you ! It’s far better but, as you can see (http://www.so-fetch.fr/), I still have a small blank space above the footer

Best regards,

Michael

Okay Michael, please try to use the following CSS code.

You can add CSS code in DashboardAppearanceCustomizeAdditional CSS (WordPress 4.7 and up). Also you can add CSS code directly to style.css file of your child theme.

div#pl-2 div#pg-2-8 {
    margin-bottom: 0;
}

Kind Regards, Roman.

P. S.
Before using the code above I suggest you to edit home page, edit the last row (not widget), expand Layout section, and make sure that there is no Bottom Margin. I guess that you have 10px there. If yes, just remove it and save changes.

Hi Roman,

You were right on the 10px bottom margin. And it works with a 40px padding for the last row (even if a small blank space ends up appearing after 5 seconds).

However, I still have a large blank space if I increase the padding of the last row. As you can see here with a 100px padding (and a 0 bottom margin). http://www.so-fetch.fr

I don’t think I have a child theme.

Hi Roman,

Problem solved ! It was the GIF format. It was not high enough.

Thank you very much for your help

Best regards,

Michael

You are welcome Michael! :slight_smile:

Kind Regards, Roman.

Hi Roman,

Sorry for reopening this topic but I just found out that the blank space above the footer still appears on Safari.

It works perfectly fine on Chrome and Firefox.

Moreover, on Safari also, I have a bold font instead of a light font (for titles)

On Chrome & Firefox
Chrome

On Safari
Safari

Best regards,

Michael

Hi,

On what Safari version are you checking? I just tried on the latest and I don’t see it.
Also, we can’t see the screenshot you’ve posted.

Hi Vlad,

Indeed. I’m checking on an old version version of Safari (9.0.1)

Chrome & Firefox
Chrome

Safari
Safari

Best regards,

Michael

Yeah I see it on smaller resolutions.
Apparently Safari isn’t handling the gif background too well with the default theme settings.
You can add this in Customize > Additional CSS:


#pg-2-8 .panel-row-style {
     background-attachment: scroll;
}

Sorry, this css doesn’t work and it adds the same blank space in Chrome too.

Chrome (after adding the additional CSS)
chrome2

I see. Well, there isn’t much to do unfortunately except switch the gif to a regular image. At least I’m not seeing any way. Sorry.

Maybe remove that code and try this too:


#pg-2-8 .panel-row-style {
     background-position: center center !important;
}

You’re a genius. It works ! :slight_smile:

Thank you very very much !

Kind regards,

Michael