Black bar on main menu instead of lines

First up, thanks for the great theme! I’ve found it easy to set up so far, but I’m having a problem with my main menu. Instead of there being a thin line and a bold line either side of the menu, the entire menu turns into a block of colour. How do I go about changing this to show the lines instead?
Thanks in advance for any help you may be able to provide.
My site is www.lisaferlazzo.com

Hi

I checked the site and you can make the change by putting the below code in your theme’s style.css file. I would advice you to use Child theme to do so.


#main-navigation > .sf-menu > ul {
    background: #fff;
}

Thanks

Thanks for replying! I created and activated a child theme and without even having to edit anything, it seems to have fixed the problem by itself. Question is now, can I just continue to use the child theme?

Yes, you can continue to use the child theme with all the feature of the parent theme and on the top of that, whatever changes you make in the child theme stays even when you update the parent theme

Hi,
can I asked the same with this page: www.quality4life.pl
is this the same change?
I want to have two lines no one bold in menu.
Best regards
R

I tried to add this modification to style.css in main folder of the theme but without CHILD folder and doesn’t work. why? is this necessary to create a child folder?

Hi Robert,

I checked your site and the above css should work for you too.

Might be you are not using it right. You can use it directly in the theme folder’s style.css at the bottom or use a child theme. I vouch for child theme because when you use a child theme the changes made to the theme remains even after the theme is updated and this theme would keep updating itself.

you would also need to add the below css to make the bottom line thinner for main navigation


#main-navigation {
    border-width: 1px 0;
}

Hope it helps!

Thanks

Hi, so I will try without CHILD version. But to be sure I will add two lines at the bottom of the file style.css of our templates one by one:

#main-navigation > .sf-menu > ul {
background: #fff;
}

#main-navigation {
border-width: 1px 0;
}

right?

not, doesn’t work :frowning:
any other options?
maybe I should not only add this two lines but delete some other lines?

yes

can you check my website? maybe I don’t see it right ?

no you dont have to do anything else… let me check. let those two lines be there

I put it on the bottom of the fasionista file

checked.

you need to add an ! important too to override.

add this instead


#main-navigation > .sf-menu > ul {
    background: #fff !important;
}

and remove ?right from the style.css file, else it could create issue later.

Thanks

works! :slight_smile: you are brilliant!!!

One more question to fonts…
at my wife computer polish font are shown right but at my is not right
I use FIREFOX and my wife use IE.
Is there any option to correct it at FF?

hi

glad it helped.

can you pls create a new thread for the new issue.

will definitely look into it

thanks

perfect :slight_smile:

I add new thread