Author and date


#1

Hi there! First things first, thanks for the great theme! it is awesome!

So, I checked the Structured Data section of the Google Webmaster Tools and it says that all my posts have missing “author” and “updated” markups. Ive tried reinstalling wordpress without any manipulation of the theme, and them I tried reinstalling the theme. I also tried to add the class “entry author” and “date updated” in the archive.php file, but I’m a noob and it didn’t work.

My site

So, any idea how can I solve this issue?
Thanks already. :slight_smile:


#2

Hi there,

The latest version of the theme fixes this issue.


#3

Hi. I recently installed the update for the fashionista theme and now the date appears twice underneath the post title. It writes 02/17/201502/17/2015

Is there a way for me to fix this?

Thanks!


#4

I’m seeing the same thing as melissach with the latest update of Fashionista: the date repeats in some posts, but not all. I can’t see any pattern to it.
See for yourself: http://discussion.movingpoems.com/


#5

Hi

With the new update the theme is showing the post modified date too, if you want to get rid off this. Add the following code in your theme’s functions.php file. I will suggest to use a child theme if you are not using one already.


function athemes_posted_on() {
	$time_string = '<time class="entry-date published updated" datetime="%1$s">%2$s</time>';

	$time_string = sprintf( $time_string,
		esc_attr( get_the_date( 'c' ) ),
		esc_html( get_the_date() )
	);
	
	printf( __( '<span class="posted-on">%1$s</span><span class="byline">%2$s</span>', 'athemes' ),
		sprintf( '<a href="%1$s" rel="bookmark">%2$s</a>',
			esc_url( get_permalink() ),
			$time_string
		),
		sprintf( '<span class="author vcard"><a class="url fn n" href="%1$s">%2$s</a></span>',
			esc_url( get_author_posts_url( get_the_author_meta( 'ID' ) ) ),
			esc_html( get_the_author() )
		)
	);	
	
	
}

Hope it helps!!

Thanks


#6

This will be fixed in the next update, which we’ve submitted and which will likely be approved in the next few days. Sorry about this.


#7

Thank you, guys!


#8

You can also download it from here and upload it manually: https://wordpress.org/themes/download/fashionistas.1.4.zip
Sorry for the inconvenience.


#9

Many thanks, especially for continuing to update a free theme.


#10

Thank you!! Appreciate the quick response.


#11

Thanks for the prompt update… Oh, and thanks for this excellent theme… I hope you will continue with it and expand its capabilities. The look of this theme is just perfect right out of the box…
Brad, Vancouver, B.C.


#12

Vlad, that theme update failed when I tried to install it. I will just wait for the update. Thanks again for making such a great theme and keeping it updated!


#13

You need to deactivate and delete the theme first, then reinstall it. Did you do that?


#14

I am also having the trouble with date showing twice on posts. I am using a child theme for fashionistas. The child theme is active. I tried to delete the fashionistas theme but I can´t find the option for it. Hope you can tell me what to do, many thanks in advance!


#15

Hi V

The issue you are reporting is fixed in the latest version.

You must be seeing the update notification for fashionista theme in the themes section, so just update it and everything will be fine for you.

Thanks


#16

Hi Matty,
thanks a lot for your response, then I will just wait until WordPress shows the next theme update.
Thanks again!


#17

Hi V

yes you can do that or you can also download it from here and upload it manually: https://wordpress.org/themes/download/fashionistas.1.4.zip

Hope it helps!!

Thanks


#18

Hi Matty,

thanks for the source, I will try that one so I don´t have to wait, great!


#19

You are welcome