Attribute Archive Not Displaying As Grid

I am currently trying to resolve an issue where my shop and normal product category pages appear in a 4 column grid however if you follow an attribute link the archive list appears as a single column… Any help appreciated.

See the issue here:
Working via regular shop links: https://staging.lovemybillylidz.com.au/product-category/accessories/
Not working via Attribute links: https://staging.lovemybillylidz.com.au/collection/dune-child-collection/

Hi,

I am sorry for the trouble.

As checked, seems likely the grid class names on each product item under attribute pages are missing.

I will be investigating this further with our development team. The permanent fix for this may come in the next version update of Leto. When it is available, you’ll just need to update the theme.

Regards,
Kharis
aThemes Support

Thanks Kharis,

Any ideas on a temporary fix or even a lead time for a new release?

Thanks for quick response!
Chris

Hi Chris,

Thank you for getting back.

  1. Find this code block in inc/woocommerce.php in the Leto theme folder
    /**
     * Helper function to check if current page is WC archive
     */
    function leto_wc_archive_check() {
        if ( is_shop() || is_product_category() || is_product_tag() ) {
            return true;
        } else {
            return false;
        }
    }
  1. Replace it with
    /**
    * Helper function to check if current page is WC archive
    */
    function leto_wc_archive_check() {
    	if ( is_woocommerce() && is_archive() ) {
    		return true;
    	}
    	if ( is_shop() || is_product_category() || is_product_tag() ) {
    		return true;
    	} else {
    		return false;
    	}
    }

Please note that this code changes will be wiped out each time you update the theme. Because all files are replaced when updating. So you’ll redo this code changes.

I hope that helps. Let me know your views.

Regards,
Kharis
aThemes Support

I’ll apply this fix now and should I assume that this will be resolved in the next theme update?

Sure, this will be permanently fixed in the future theme updates.

Regards,
Kharis
aThemes Support