AT Tabs is not working properly

Hello! My website is www.1001TeaFacts.com. I am using the theme Fashionista and I have the AT Tabs installed in my sidebar widget area. It was functioning properly utnil lately. For some reason when I click on “Latest” and “Tags” it doesn’t seem to work. Rather it still shows the “Popular” section. Could you tell me why is that happening? I tried to reinstall it but it still doesn’t work. Please respond as soon as possible,
Thank you in advance!

Hi S

I checked the site and found the issue. I checked with version 1.5 of the theme and seems there is some js issue. I will report this to the theme author, in the mean while please follow the below steps and get it fixed for the time being.

  1. create a file name custom.js inside fashionistas(theme)/js so the path will be fashionistas/js/custom.js

  2. add the below js in the file and save it


jQuery(document).ready(function(){
	jQuery('#widget-tab li').click(function(e){
		e.preventDefault();
		var activeTab = jQuery(this).children('a').attr('href');
		jQuery('#widget-tab li').removeClass('active');
		jQuery(this).addClass('active');

		jQuery('.widget-tab-content').children('div').removeClass('active');
		jQuery(activeTab).addClass('active');
	});
});

  1. add the below line in theme’s functions.php file after line 179, which read as
	wp_enqueue_script( 'athemes-settings', get_template_directory_uri() . '/js/settings.js', array( 'jquery' ) );

the new line to be added is

	wp_enqueue_script( 'athemes-custom', get_template_directory_uri() . '/js/custom.js', array( 'jquery' ) );

now save and check. This must have fixed the issue.

Hope it helps!!

Thanks

This fixed worked for me.

Only difference is the text you quoted isn’t on line 179, but 357.

Thank you :slight_smile:

Hi Abbie,

Glad it worked.

And about line number, it may differ if you have custom coded already.

Nevertheless It worked is what is important :slight_smile: