Animation speed control

Hail to the king of support :slight_smile: Vlad!

I have 2 questions:

  1. The animation loads very slow on a mobile device, but I like the effect so I dont want to disable it just make it appear faster.
    Where can I find the piece of code that controls the speed of the animations?
    What is th custom CSS to edit the speed of the animations?

  2. since version 1.14 the menu button is not centered anymore when I visit my site with my IPhone. It sticks to to top of the header.

  1. Have a look in animate.css. It won’t be easy to change it.
  2. Seems like the new code isn’t working that well with your short title. Use this in a custom CSS plugin:

@media screen and (max-width: 320px) {
    margin: 40px auto;
}

  1. Sorry Vlad I don’t understand your istructions. I have looked for animate.css but i didn’t find it through the editor.

  2. No sollution yet. The probem occurs on the iphone 4s in the portrait position, landcaoe is ok. Bigger screens, and newer versions of phones are ok i tested it on the Iphone six and everything works really smooth.
    But the issue occurs on small screens.

So is there something else I can do to change the position of this burger menu so it would look nice also on the smaller screens?

P.s. did You have time to check the email isue?
After this issue is solved I am buying the PRO version for sure. Even if it is only to give something back for all your time and effort :slight_smile:

  1. You would need to download the theme and open up the zip file and you’ll find it in the CSS folder. But seriously, it’s not a good idea to modify it, don’t you want just to turn the animations off for mobiles?

  2. Sorry, the code I gave you is wrong and it makes no sense. I was probably in a hurry at that time. Use this:


@media screen and (max-width: 320px) {
   .menu-toggle {
      margin: 40px auto;
   }
}

I checked the email and it’s working for me. Maybe try a different plugin.

  1. That would be nice, how do i disable the animations for mobile devices only? Because the customize disables the animations for all devices.

  2. Great the menu is centered properly. Many Thanks!!!

  3. I am using form 7 just like the documentation suggests. The weird thing is If I send the mail from the footer locations then it works and arrives properly, but when I use the contact page same plugin but a customization of the form, then it has limited symbols I can enter and even when i send the mail it arrives empty.

Maybe related to this issue that the page title in the url are not the same as in page builder. How this is possible I dont know.
For example:

Page title: contact
Page URL: http://jullo.nl/contact-us/

Page Title: Blog
Page URL: http://jullo.nl/photo-gallery/

  1. You would need to go to functions.php and find this line if ( get_theme_mod('moesia_animate') != 1 ) {. Replace it with this:

if ( (get_theme_mod('moesia_animate') != 1) && !wp_is_mobile() ) {

Try not to break your website while doing this.

  1. I have no idea what the issue is but I don’t think it can be theme related. Try to add a new page and just add the contact form shortcode in it, without using the page builder. So just a regular page.
  1. I found the code and replaced it just like you said and i broke it just like you said hehe.
    Just kidding , it is not broken but the code is not working properly. The animations still work, but now they appear and dissapear, and then they are solid. But it is not the expected action.

  2. I found that it is my own customizations of the plugin that makes it crash. I added a new form and it works, yet now I have to change the layout properly.

I guess wp_is_mobile isn’t detecting your mobile, which is strange since that is a WP core function and it usually works well. Revert back to the old code.

Let’s try something else for now. Add this to your custom CSS plugin:


@media screen and (max-width: 1024px) {
   .animated {
      -webkit-animation: none !important;
      animation: none !important;
   }
}

This one is great! it works like a charm, my site loads fast and smooth.

Many thanks!