Anchor problems

Hi !

I’m currently creating a website on Quill :slight_smile: I love your theme but I have a little problem with the creation of HTML anchors.

With the widget SiteOrigin Button I have added some buttons on the Home page and I would like them to lead the users to some HTML anchors on an another page but it doesn’t work. The link to the page is working but not the anchor : when I click on the button I go to the top of the page…

I use the following :
Destination URL : page.html#anchor (on the button)
<div id=“anchor”></div> (on the destination page)

Is there something I’m doing wrong ? Do you have any solution ?

Thank you for your help !

Marièke

PS : The website is http://www.celinebouvierbarache.com (it is mostly in French).

Hi,

Please post a link to the page where you want the button to be linked and the exact URL you tried to link it to the anchor on that page.

Best Regards,
Csaba

Thanks for you reply :slight_smile:

The “read more” buttons are here : http://celinebouvierbarache.com

The page where I added the anchors is http://celinebouvierbarache.com/mes-services

Marièke

Hi,

The site is in maintenance mode, please deactivate that plugin, so I can check your site and also post the link you want to use ( with the anchor ).

Best Regards,
Csaba

Ah ! I’ve just put it in maintenance mode because of my customer… :s I can desactivate it for some minutes but I will activate it again :wink:

Now it is desactivated :wink:

Hi,

Ok, Please post a link to the place where you want to link your button ( the full link with the anchor ), so I can check why that wasn’t working.

Best Regards,
Csaba

Hey !

I add to hide the website again as my customer really doesn’t want the website to be online :s I’ll update this message when the website will be on air :slight_smile:

Sorry for the inconvenience !

Hi !

It’s me again !

The website is online now and my anchor problems are still existing.

One the page http://www.celinebouvierbarache.com (this is the home page) I have six buttons which leads to the page http://www.celinebouvierbarache.com/services. However, I would like them to lead to this page AND to go down until the right service.

Could you help me? I’ve settled some anchors but they doesn’t seem to work.

Thanks !

Hi,

Do you mean the 6 “Read More” buttons? How I see they are linked will to anchors on that page.

Best Regards,
Csaba

Hi :slight_smile:

Yes I mean these buttons. I’ve just realised that the anchor work on Chrome but not on Safari and Firefox… Have you seen that kind of behavior before ?

Best regards,

Marièke

Hi,

That’s weird, because for me the anchor works in Safari and Firefox too, juts have to wait a bit to load the page, then it goes to anchor, in Chrome is faster, so maybe that’s why you think it’s not working.

Best Regards,
Csaba

Hi !

Still working on this problem actually :s

It’s working on Firefox and Chrome but not on Safari. I use Version 9.0.3 and you ?

Best regards,
Marièke

Hi,

I use Safari 9.0.3 too ( Safari Version 9.0.3 (11601.4.4) ) / MacOSX ( El Capitan ) Version 10.11.3 on a 15" MacBook Pro Retina and for me it works.

Best Regards,
Csaba

Well thanks a lot for your help!

Sometimes I don’t understand my computer. I’m on MacOSX Yosemite, maybe that’s why the links are not working. It’s ok for my customer so I’ll leave this website that way :wink: This issue is closed :slight_smile:

Best regards,
Marièke

Hi,

Ok, Great! I’m glad it’s resolved! If you need help with anything else, please open a new topic.

Have a nice day!

Best Regards,
Csaba