All widgets gone

Hi,

I’m in the middle of building a new site with Astrid and this is my testing site. Once finished I will switch the domain,
http://vizitstudio.sakura.ne.jp/astrid/

I installed and configured Yoast SEO plugin and then all the widgets are gone. I searched the forum and saw some people have the same issue but didn’t find any solution for how to recover those widgets.

This same issue happened to me twice already when I changed something which I don’t remember. Anyway, I rebuilt it adding Service, Project, etc again and got tired of it this time so decided to ask here.

Is there any way to get them back or do I need to rebuild again?

thanks

Hi,

There might be something else that caused this, don’t think it’s Yoast. Basically it should only happen if you switch the page template. If you go to Appearance > Widgets, you should find all your widgets under Inactive and you can just drag them back.

Yes, I already tried that, drag them back in the front page pulldown. That drag and drop works but all disappear after page refreshing. I have a big pile of Inactive widgets from previous ones now and want to clean it up.

I never switched all page templates from the imported demo ones but I use WooSidebars to hide the sidebars for project pages. I also set the site language to Japanese. I kinda think some features are not supported for Japanese.

Perhaps there’s something in your setup that isn’t working well with Astrid’s way of doing things. Not really sure what to tell you.
So you add your widgets then go visit your homepage and the widgets aren’t showing after you refresh?

Yes, not showing at all. I tried bunch of time in different ways.

I just grab the widgets in the Inactive and drop it in the front page dropdown, refresh the widget page and then those are gone, not saved. I don’t see any button to save the change if any. BTW, I have that original front page dropdown, above that the original sidebar dropdown with bunch of default widgets, and at the top WooSidebars dropdown with nothing in it. Does that top one wipe all widgets out?

Well, I think I have to start rebuilding and hope it won’t happen again. Please let me know if you find any solutions.

I thought you were refreshing the frontend.

Try to add your inactive widgets back where they need to be and click on Save for each of them.

Yes, I did refreshing the front end, too. Also, I tried clicking on the save button in the dropdown of the widget after drag dropping it and repeat the same for the rest. I tried all that I could think of but none of them worked.

Anyway, I just finished rebuilding, it took me 30~40 mins.

I’d like to ask you other questions. I added a gallery on a project page and need to edit those single pages. How can I remove the first image that is associated with the Project widget? and I’d like to set the background color to be white. Is there any way to do it?

thanks for your help as always.

This in Customize > Additional CSS:


.page-template-single-project .single-thumb {
    display: none;
}

If you go to Customize > Colors, the first option is the background color.

I added that code in my child theme’s style.css first and also tried it in Customize > Additional CSS, it still shows the featured image from the project widget. Any other advice?
http://vizitstudio.sakura.ne.jp/astrid/interior/

I changed the background color to white from Customize > Colors. It worked but left thin lines, maybe border? Can I remove them and make the background all white?

Sorry, I’ve edited the previous code.

Here’s for the borders:


.hentry,.site-content > .container { border: 0;}

Did you change the code for the Project featured image???
I thought you provided me this code first and it didn’t work,

.page-template-single-project .entry-thumb {
display: none;
}

but now this one works,

.page-template-single-project .single-thumb {
display: none;
}

What’s the “.entry” referring to?