All Blog Posts link to One page? Error Help


#1

www.awakenedintimacy.net/blog

All my blog posts mysteriously link to my work with us page. I can’t even manually change the permalink. What’s going on here?

Thanks for your help
Ender


#2

I’m guessing you have a plugin that’s causing this issue. Try disabling the plugins one by one and see if the problem is solved.


#3

Thanks for your response,

I just deactivated everything one by one, no luck. I have them all off right now except for ‘Page Builder by SiteOrigin’ because when I turned it off, it killed my whole site.


#4

My friend provided the following input, I’m not sure if it helps.

“Very likely a bug in the theme. Quite a lot of links end up pointing to /workwithus – sounds like someone messed up a simple variable assignment in the php code and now each link is the same throughout a given loop or so.”


#5

There is literally nothing that can be messed up from the theme regarding those links. You can tell your friend that this is the code that shows the title:


<?php the_title( sprintf( '<h1 class="entry-title"><a href="%s" rel="bookmark">', esc_url( get_permalink() ) ), '</a></h1>' ); ?>

It’s a default WP function so there is nothing specific to the theme here.

Furthermore, it works properly on my test server and on the theme demo, so this issue is related to your website in some way.

Do this please: go to Settings > Permalinks and click on Save Changes without making any changes.

If it doesn’t fix it send an admin account for me at vlad[at]athemes.com and I’ll have a look. Also let me know if you made any code changes.


#6

HA! YES!

You’re awesome Vlad, thanks for your patience with me. The wrong option got checked when I was messing with the site pre-launch. I had inadvertently set the permalinks to our /workwithus page.

Problem solved.

Thanks again for all your support.
Ender


#7

Cool, glad you figured it out.