Airi Pro Font Display

Please can you assist with a font display problem using Airi Pro.

Error on the site: 404 Failed to load resource for my font .woff files

All the pages I have created using Elementor on my staging website are displaying correctly. However any pages created not using Elementor are not displaying default fonts correctly. ( e.g. https://stomaza.wpengine.com/terms-and-conditions/ or https://stomaza.wpengine.com/news-and-events/ )

So the fonts are not reflecting what has been chosen in the Customiser and in addition, are not displaying based on the CSS I have added, which is:

.main-navigation a {
font-family: ‘Merriweather’, sans-serif;
color: #191919;
font-weight: 500;
font-size: 1.0rem;
text-transform: none;
}

body {
font-family: ‘Open Sans’, sans-serif;
font-size: 18px;
font-weight: 300;
}

h1, h2, h3, h4, h5, h6 {
clear: both;
font-family: ‘Merriweather’, sans-serif;
color: #191919;
font-weight: 500;
}

Would appreciate your help. Many thanks!

Hello,

Please can you assist with a font display problem using Airi Pro.
Error on the site: 404 Failed to load resource for my font .woff files

How exactly did you add those fonts to your website?

Did you try to use the CSS @font-face at-rule?

Kind Regards, Roman.
aThemes Support

Thank you for your reply. I have just now added the google fonts to the head tag, which seems to have solved the problem.

I had not added any fonts previously, I was just selecting the font from the Airi Pro Customiser.

Many thanks, Tracey

1 Like

Okay Tracey, you are welcome!

Please feel free to ask any other questions that you might have in future.

Kind Regards, Roman.
aThemes Support