Airi 1.0.7 and 1.0.8: can't use Elementor editor! :-(

Hi everybody,
i have the same error in May, before the Airi release 1.0.5: now i can’t complete the 1.07 update! :tired_face:

When i go to “Edit with Elementor”, i have this message:

PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘Airi_aThemes_Blog_Skin_6’ does not have a method ‘skin_print_template’ in D:\inetpub\webs\MYWEBSITE\wp-includes\class-wp-hook.php on line 286

Moreover, in style.css page i notice a waring like this:
“There are 2 errors that must be solved before updating this file.”
The errors are the following:

  1. line 3842 grid-template-columns: repeat(3, 1fr); —> Expected RBRACE at line 3842, col. 36
  2. line 3843 grid-template-rows: repeat(3, 1fr); —> Expected RBRACE at line 3842, col. 33

In short: i can’t use Elementor editor, but just WP editor :sob:

Can someone help me please???
Thank you in advance,

Barbara

Hello Barbara,

I couldn’t recreate this issue on my local Airi install, so can you please provide a link to your website in order to let me check it?

Kind Regards, Roman.
aThemes Support

Hi Roman,
the error isn’t visible online, so i think i can create a user for you to enter in one of my website to check it, ok?
Thank you

Hello Barbara,

Can you please try to deactivate all your plugins except Elementor and Kirki Customizer Framework first, and see if it helps?

Kind Regards, Roman.
aThemes Support

Hello Roman,
i’ve done what you suggested, after update Elementor to 2.7.1 edition, but the situation is still the same.
Thank you, kind regards

Barbara

Okay Barbara,

Please check Elementor requirements and make sure that everything on your end meets them:

Kind Regards, Roman.
aThemes Support

Hi Roman,
I confirm you that my website respect Elementor’s requirements.
Thanks

Hello Barbara,

You can try to rebuild your website in a staging environment or locally and see if it works as it should (then you will be able to move the rebuilt website to production environment).

Here are the relevant tutorials:


Kind Regards, Roman.
aThemes Support

Hello Roman,
while i’m trying to implement what you suggested, i received the notice to a new elementor release (2.7.2). After a total backup of the site, i did the update required.
Now on my board i have this message from Elementor:
“Elementor data update – The database update process is running in the background.
Taking a while?” with the button “Click here to run it now”.
Then, if i click the button, i receive this error:

PHP Fatal error: Uncaught Error: Class ‘Airi_Google_Maps_Skin’ not found in D:\inetpub\webs\MYWEBSITE\wp-content\themes\airi\inc\compatibility\elementor\skins\class-airi-google-maps-skin.php:185
Stack trace:
#0 D:\inetpub\webs\MYWEBSITE\wp-includes\class-wp-hook.php(286): {closure}(Object(Elementor\Widget_Google_Maps))
#1 D:\inetpub\webs\MYWEBSITE\wp-includes\class-wp-hook.php(310): WP_Hook->apply_filters(’’, Array)
#2 D:\inetpub\webs\MYWEBSITE\wp-includes\plugin.php(465): WP_Hook->do_action(Array)
#3 D:\inetpub\webs\MYWEBSITE\wp-content\plugins\elementor\includes\base\widget-base.php(131): do_action(‘elementor/widge…’, Object(Elementor\Widget_Google_Maps))
#4 D:\inetpub\webs\MYWEBSITE\wp-content\plugins\elementor\includes\managers\widgets.php(85): Elementor\Widget_Base->__construct()
#5 D:\inetpub\webs\MYWEBSITE\wp-content\plugins\elementor\includes\managers\widgets.php(235): Elementor\Widgets_Manager->init_widgets()
#6 D:\inetpub\webs\MYWEBSITE in D:\inetpub\webs\MYWEBSITE\wp-content\themes\airi\inc\compatibility\elementor\skins\class-airi-google-maps-skin.php on line 185

And when i try to edit page or article with Elementor i always receive the same “old” error (PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘Airi_aThemes_Blog_Skin_6’ does not have a method ‘skin_print_template’ in D:\inetpub\webs\MYWEBSITE\wp-includes\class-wp-hook.php on line 286

Now… what i have to do? :sleepy::sleepy::sleepy:

Hello Barbara,

I’m tagging onto your post because I seem to be having the same problem with the Elementor Database Update. I was on Airi 1.07 and got a message from WP that says:

Error Details

=============

An error of type E_ERROR was caused in line 185 of the file /home/tdogus5/public_html/wp-content/themes/airi/inc/compatibility/elementor/skins/class-airi-google-maps-skin.php. Error message: Uncaught Error: Class 'Airi_Google_Maps_Skin' not found in /home/tdogus5/public_html/wp-content/themes/airi/inc/compatibility/elementor/skins/class-airi-google-maps-skin.php:185

Stack trace:

#0 /home/tdogus5/public_html/wp-includes/class-wp-hook.php(286): {closure}(Object(Elementor\Widget_Google_Maps))

#1 /home/tdogus5/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)

#2 /home/tdogus5/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array)

#3 /home/tdogus5/public_html/wp-content/plugins/elementor/includes/base/widget-base.php(131): do_action('elementor/widge...', Object(Elementor\Widget_Google_Maps))

#4 /home/tdogus5/public_html/wp-content/plugins/elementor/includes/managers/widgets.php(85): Elementor\Widget_Base->__construct()

#5 /home/tdogus5/public_html/wp-content/plugins/elementor/includes/managers/widgets.php(235): Elementor\Widgets_Manager->init_widgets()

#6 /home/tdogus5/public_html/wp-content/plugins/elementor/includes/elements/column.php(1025): Elementor\Wid\

SO it appears that we have the same problem!

But, after upgrading to Airi 1.08 just a moment ago, I get the same button to “run it now” and the page just refreshes, but the button remains and no more email from WP.

Hoping our aThemes folks down unda can help us!

Trace

Hi there,

I’m gonna need one of you to please send me an admin account to vlad[at]athemes.com so I can check.
This seems specific to your websites somehow and I’d like to figure out why.

Hello Vlad,
thank you for your support.
I’m createting an admin account for you, you’ll receive an email asap.

Issues handled over email.

Super rapid and very kind: THANK YOU so much Vlad, you’re GREAT!
:star_struck::star_struck::star_struck::star_struck: