Activate Template under Page Attributes for Custom Types

Hi, there.

I’ve been using Athemes for the last year and GreatMag was my first experience without Toolset Types.

I installed it so I could word with a better post organization with Types.
The only problem was I could activate Attributes > Template on the new Type.

I’ve tried activating hierarchical and also atributes on the Types as in other templates but it hasn’t worked.

Any thoughts to share on this one?

Thanks!

Hello André,

Can you please describe what exactly you want to achieve?

Kind Regards, Roman.

Hi Roman

Thanks for the reply.

Basically I want to enable the selection of different page templates (fullwidth and others) on a Custom Type, created on Toolset Type.

The same way it is in other Athemes templates such as Sydney and Perth (although I read you are not using Toolset Type anymore).

Basically the steps to get here was:

  1. Create Custom Type (like Services or Team)
  2. In this new Custom Type, allow Hierarchical, so I can enable Template selection on this new custom type post.

Here is a printscreen of what should be:
https://drive.google.com/open?id=0B9KHiBLeGEAZLV9SckpRTFVWLU0

What I am getting:
https://drive.google.com/open?id=0B9KHiBLeGEAZZDNhcXpYYnluTDg

What I am configuring on Toolset Types (according to some instructions).
https://drive.google.com/open?id=0B9KHiBLeGEAZVDVwSlpkV000YWc
https://drive.google.com/open?id=0B9KHiBLeGEAZSl9GVGgyQ3VYRVE

The thing is, it works for other Athemes templates, but is not working on Greatmag.
I’d like to know what I should do to get this working on this template.

Thanks again!

Hi, Roman.

I guess I forgot to hit Submit. =P

I need to activate Template dropdown at Page Attributes on a Custom Type Post, so I will be able to select Fullwidth or other page layout options for Custom Type Post like on the image below:
Screen Capture - Template enabled

As if I just went to Sydney Pro template and:
Toolset types > Post Types > Services and activated hierarchical and Page attributes.

It does work that simple on Sydney Pro with Toolset types, but on Great Mag, I don’t get the dropdown menu, like on the image below:

I do not understand why this option just won’t work on Great Mag Pro. =/
Screen Capture not enabled

Thanks agains!

Hello André,

It looks like your posts were caught by spam filter, I unspammed them and deleted duplicates and the test post.

Regarding your issue, please check this link:
https://developer.wordpress.org/themes/template-files-section/page-template-files/

I’m not sure how page templates can work for custom post types in Sydney Pro, its page templates don’t have Template Post Type: property specified.

Kind Regards, Roman.