406 Error when trying to add images with links into page


#1

I am trying to set up my new website bryanfreemanphotography.com.au
I am setting up a page with the title “Links”. I am using various images of logos for FB, Twitter etc and attaching a link to those images that will send the user to my particular social media page.
THe problem I am encountering is that I keep getting a 406 error message that won’t allow me to insert the logo into the page, with or wothout a link.
I really like this theme and I was about to buy the pro version as I need the mobile pages as well but I can’t buy it if I can’t insert images into the pages.

Thanks,
Bryan


#2

Dear Bryan,

I was thinking that the wp-content directory isn’t writable. Could you please try to change its permission into 755 through cPanel or FTP?

If it didn’t help, make sure there is enough space in your host.

Warmest regards,
Kharis


#3

Hi Kharis,

Thanks for your response.
Do I need to change the permissions to 755 on every file in the WP Content directory or just certain files?

Thanks,
Bryan


#4

I’ve changed it on some files but there’s 100’s of files in various folders in the WP Content directory


#5

BTW, I’ve got unlimited space with my Host and the images I’m uploading have been optimised to 72dpi.


#6
Do I need to change the permissions to 755 on every file in the WP Content directory or just certain files?

You should need to set the permission of wp-content > uploads directory; and all directories inside it.

Let me know how it goes. I’ll wait to hear back from you regarding your stats.

Warmest regards,
Kharis


#7

Looks like I’ll be uninstalling this theme and going with one where I don’t have to do any of this additional work. The last theme I bought worked without all this hassle. I use Wordpress themes as they’re supposed to be ready/easy to use without any hassle!


#8

Ok, it appears the problem is with all themes, not just this one so I’ll continue on with it as it is a nice looking theme.

I did change all the permissions in the Uploads directory to 755 but it still doesn’t work.

I’ve put in a support request with my Web Host and am waiting for them to respond.

Thanks for your help. :slight_smile:

Regards,
Bryan